Carter - Payment Error – Incident details

All systems operational

Payment Error

Resolved
Major outage
Started over 3 years agoLasted 31 minutes

Affected

Business app

Major outage from 7:33 AM to 8:04 AM

Updates
  • Resolved
    Resolved

    This issue has now been resolved.

  • Investigating
    Investigating

    All merchants are currently facing a payment error when processing a delivery request. We are working to resolve the issue.